TweetiePie for WordPress

posted on 07.19.09
, ,

Twitter Bird

I finished up my new WordPress plugin, and I’m excited to announce it here. It’s called TweetiePie and its’ purpose in life is to bring in your most recent updates from twitter and put them on your blog.  This can be done by using a widget or as a direct function call. It’s super-easy to get your tweets on the sidebar.  Simply supply your username, how many tweets you would like to display, and whether or not you would like to show the date.  Here is a screen-shot of it in action at sixmonthexperiment.com:

TweetiePie in Action

It also linkifies hash tags and @replies and properly caches.  In case you didn’t know, caching is used to minimize the times that your blog has to talk to twitter.  This will speed up your site and keep twitter happy.  It is called TweetiePie because it uses the SimplePie WordPress plugin to pull the tweets from twitter and cache them.  TweetiePie requires version 2.8 of WordPress or higher.  I’m not going to say much more than that since all of the technicalities and details are where it resides, in the WordPress plugin directory.   Please leave all technical questions there and I’ll leave this space open for comments on how this plugin has helped you, if you absolutely hate it and think I suck, etc. etc. etc.

If you feel so inclined to donate, I’ll happily use the money to help pay off my student loans.





22 Comments
 
  1. Vicktorya says...
    VICKTORYA.COM
     
    7.19.09

    “speak”, cute. :-)

    I really like your plugin, but it requires simplepie, and simplepie is not compatible past 2.5 … right?

    Do I still download simplepie, and tweetiepie will work fine?

    Thanks — thought I’d ask before putting it on.

    best,
    Vicktorya

    reply
  2. elightbo says...
     
    7.19.09

    Hello Vic,

    Thanks! From what I can gather the authors of the simplepie wordpress plugin haven’t updated that page in some time. SimplePie has run successfully on versions 2.7 and 2.8 for me. Just know that my TweetiePie plugin requires version 2.8 of WordPress. Thanks for checking the plugin out!

    reply
  3. Ate Sienna says...
    atesienna.pansitan.net
     
    7.19.09

    why am i getting this error when i try to active the plugin?

    Fatal error: Class ‘WP_Widget’ not found in /home/pansitan/public_html/atesienna/wp-content/plugins/tweetiepie/tweetie_pie.php on line 119

    reply
    • elightbo says...
      ericlightbody.com
       
      7.19.09

      That WP_Widget error is from having a version of WordPress less than 2.8. I had documentation about TweetiePie requiring at least version 2.8 in the plugins directory, but I should probably add it here as well. Once you upgrade WordPress you won’t have that problem anymore.

      reply
  4. baron says...
    turkbaron.net/
     
    7.20.09

    Works great, thank you

    reply
  5. Jamie says...
    mediarosa.com
     
    7.20.09

    Thanks Eric! Just installed your plugin and works great. Just what I wanted.

    reply
  6. Vicktorya says...
    VICKTORYA.COM
     
    7.20.09

    Ok, thanks again — this works just fine. Much appreciation and happy tweets and such.
    Vic

    reply
  7. John Lewis Zoeckler says...
    sixmonthexperiment.com
     
    7.21.09

    ERIC,

    Thanks for the great twitter plugin. I have tried a bunch of others with various levels of frustration. Yours is working great and my site remains fast.

    reply
  8. Patrick says...
    patrickrauland.com
     
    7.21.09

    Wow. How fantastic that you created that plugin. Props.

    reply
  9. elightbo says...
     
    7.22.09

    Thanks for all the feedback!

    reply
  10. Marko says...
     
    8.11.09

    Hi Eric,

    Thanks for the plug-in, it works great. :-)

    I have a feature request: what about adding a simple “Follow me on Twitter” linking to one’s own profile page?

    That’s the only thing missing for me.

    Thanks again and take care,

    Marko

    reply
    • elightbo says...
      ericlightbody.com
       
      8.12.09

      Hi Marko,

      Thanks for the feedback! I’m very happy that the plugin is working for you. I like the idea, and have a couple more I’ll be adding on the next version.

      reply
  11. Ruy Adorno says...
    ruyadorno.com
     
    8.12.09

    I really liked your plugin and I’m installing it on my new blog, here are just some small notes to improve it:
    1- The @ placed outside of the link tag in the username link may broke some themes (it happened on mine).
    2- Please keep it simple, that’s the main reason I picked your plugin.
    Many thanks and congratulations for the good work!

    reply
  12. elightbo says...
    ericlightbody.com
     
    8.12.09

    Thank you Ruy, it’s always great to hear that people are using it. Just out of curiosity, what theme were you using? I would like to try and duplicate the error. Thanks!

    reply
  13. Nokia Themes says...
    themes2.com
     
    10.31.09

    great name haha, makes me laugh. But damn, another great app for twitter

    reply
    • elightbo says...
      ericlightbody.com
       
      10.31.09

      Ha! At first I thought you meant my last mane! Really glad you like the plugin.

      reply
  14. Angela says...
     
    11.4.09

    Hey, I have been looking for this plugin for a long time. Glad I’ve found it. Now I would like to know how do I create a direction function call for my twitter account, because when I put this “” in my sidebar, it has your tweets like you said. Not sure how to create one for myself :-(

    reply
    • elightbo says...
      ericlightbody.com
       
      11.4.09

      Hi Angela…chance to pimp your twitter name here…if you use this code:

      < ?php gettweet_tp("elightbo", 2, true, true)?>

      replace elightbo with your username and you should be all set.

      reply
  15. Alessio says...
     
    11.18.09

    Nice plug in.

    There is an error when used on a PHP 5.2+ engine which states: “Nesting level too deep – recursive dependency?”

    To fix this go to line 101 of tweetie_pie.php and change:


    if ( $item != end($feed->get_items())) {
    $tweet_group .= $between_tweets;
    }

    to


    if ( $item !== end($feed->get_items())) {
    $tweet_group .= $between_tweets;
    }

    Notice that if statement compares on a more strict level. Pre PHP 5.2 there would be NO error but PHP 5.2+ there will be one.

    cheers

    reply
  16. Stephen says...
    thedressagehusband.com
     
    12.4.09

    Hi,

    I have activated on WordPress 2.8.6 and it blocks the scroll bar and thereby makes my site unreadable. I am not sure what the space requirements are as I tried to install in the sidebar. Is that the problem or is there a compatibility issue? Thanks

    reply
  17. Jackelyn says...
     
    5.6.11

    Is it possible for the tweets to never expire? It seems that after a certain amount of days, if there isn’t a new tweet…the old ones disappear. My client only tweets once or twice a month, but we would like the old tweets to appear on her website still.

    thanks tons

    reply
  18. Jim says...
    diversesurf.com.au/
     
    11.3.11

    I’ve had frustrations with other twitter plug-ins. Will try this one out. Thanks, Eric. Hope this will work on my blog nicely.

    reply
1 Trackback
 
  1. By TweetiePie on July 20, 2009 at 9:53 am

Speak your mind

Email is never made public. If you would like a profile picture to show next to your comments, setup a Gravatar account

*
*